This document is a summary of common questions on getting started with FirstMagic.


For support, and for more detailed information, please contact a FirstMagic Partner or visit support.firstmagic.net.



 Installing FirstMagic for the first time
Compatibility

  

What is the server requirements?

FirstMagic is released for FirstClass / IS, v. 10 and newer, on all platforms. Web Services is not required unless you prefer users to edit their sites via FCWS and/or FirstClass Go.

Will FirstMagic affect the operation of other web publishing products installed on the server?

No.

Installation


 Will the installation procedure interrupt any running services?

No. Installation takes a few minutes, and will not tax the server in any perceptible way.

What gets installed?

The installer creates a plugin in /Internet Services/Plugins/. Unpacked, the plugin uses about 30 MB of disk space. There are no separate executables.

How do we uninstall FirstMagic?

Simply deleting the plugin will remove all traces of FirstMagic from the server.

Creating websites


Will the installer make websites?

The installer deposits an alias on the Administrator┬┤s Desktop named FirstMagicPlugin. Inside is a Wizard that creates websites on demand. It can produce single sites manually, or it can be scripted to mass-produce them. Making a single site only takes two mouse clicks. 

Using FirstMagic


Will FirstMagic replace our intranet?

No. FM can be a separate, highly specialized User Interface to the intranet, and it will inherit privileges from it if you make intranet containers available to it, but it does not replace anything. 

Do we need an intranet to operate FirstMagic?

No. Web Editors will need accounts on the server, but they do not need e-mail, conferencing, or other intranet functionalities. Nor do they need the FirstClass Client, FCWS, or other client software.

Upgrading to FirstMagic 4 from existing FirstMagic Installations
Upgrading from FM2.1+


How do we upgrade an older FM site to FM 4?

Any FM website that is v.2.1 or newer can be upgraded to FM4 automatically by running the supplied Updater. The update just takes a second.


Note: If the site uses the FM SkinDesigner, make sure the active Design Theme is properly installed before upgrading, or you must re-install the theme by hand afterwards. A guide for this eventuality is provided with the installer package.

Will the FM4 installer affect our existing FM websites?

No. Pre-existing sites must be upgraded with the supplied Updater script described above.

Do we need new licensing for FM4?

Pre-existing FM 2.1 and newer sites will not need new licensing whether you choose to upgrade them or not: all 2.1+ licenses will continue to work as normal in any existing site.


However, you can not use such licenses to generate new FM4 sites, i.e. for  sites created after the installation date of FM4. If you want to use an older, unused license on a new site, you must obtain a new license for this site. If the license is currently in the M&S program, it will be exchanged free of charge on request from your FirstMagic partner.


FM2.0 and older sites also requires new licensing if you want to upgrade them.  If your Maintenance & Support agreement is current, new FM4 licenses will be supplied free of charge on request.


Can we make FM3 sites after installing FM4?

No. New sites will automatically become native FM4 sites.

We prefer to use FirstClass / FCWS / Gmail / Outlook / homegrown / for our publishing. Can we continue with this after the upgrade - even when making new sites?

Yes. Your users can migrate to the FM4 environment if they wish, but doing so is entirely optional. 

Can we downgrade from FM4 to FM3 after trying it?

No: if you install FM4, new sites you create will become FM4. But existing FM3 sites will continue to be FM3 until you choose to upgrade them.

Upgrading from FM1 and 2.0 to FM4


Will the FM4 installer affect existing FM1 websites?

No. FirstMagic 4 is completely separate from FirstMagic 2+.

 How do we upgrade a FM1 or 2.0 site to FM4?

Create a new FM4 site, move your content to it, and port the design [or give the site a FM4 Theme].

 Do we need new licensing for FM4 for our FM1 or 2.0 websites?

Yes. You can enroll FM1 sites in the M&S program to obtain such licenses. If you have a 2.0 site and a current M&S contract, your FirstMagic partner will exchange its license at no cost.